Getting Started Guide (New sections added for 2.6.0)


Welcome to Cytoscape, a free open-source software application for visualizing and analyzing networks. This Getting Started Guide will show you the basic steps for creating a network from your data, while highlighting relevant sections of the Cytoscape User Manual that provide more in-depth information.

Cytoscape creates networks, where nodes of the network represent objects (such as proteins) and connecting edges represent relationships between them (such as physical interactions). Once this basic network is created, various attributes of the nodes and edges (such as protein expression levels or strength of interaction) can be added to the network and incorporated as visual cues like shape or colour. Networks can then be analyzed in many different ways using "plugins".

Before Getting Started

To use Cytoscape, you will need:

Part 1: Loading Your Interaction Data

Step 1: Open Cytoscape by clicking the Cytoscape icon created during installation.

Note: Alternatively, Cytoscape can be opened in Windows by double-clicking cytoscape.bat or cytoscape.jar, or in Linux/Mac OS X by running Cytoscape can also be started directly from the command line. See also "Launch the Application" and "Command Line Arguments".

Step 2: Select your data file by choosing one of the following options, depending on the file to be opened:

Step 3: Click Import to load the network. Cytoscape will display a progress screen as it loads your data. Check that the status is successful, then click Close.

Step 4: You can repeat Part 1 multiple times; that is, you can load many networks in separate Cytoscape windows. To switch between networks, click on the filenames at the left-hand side of the screen.

Part 2: Viewing Your Network

Step 1: If a network is not displayed after successful loading of your data, create a view of your network by going to Edit → Create View. Small networks will have a view automatically created when they are loaded, while large networks (i.e. thousands of nodes and edges) will be loaded without a view. Larger networks will be slower and harder to work with, due to their need for greater computational resources. However, they can be reduced to a selected subset of nodes and edges using the Filters function and then viewed as a smaller network.

Step 2: Apply a layout using the Layout menu. Applying a layout to a network moves the positions of nodes and edges to reduce overlap and provide a clearer visual representation of the data.

Step 3: Adjust the viewing magnification of your network. There are five navigation tools:



Part 3: Saving Your Network

Step 1: Save your network using the Save or Save As… options in the File menu. This saves your network as a Cytoscape-specific .cys file, which you can then open for further viewing or editing at a later time. You can also share these Cytoscape session files with collaborators, allowing them to use the network as well.

Step 2: You can export your network as an image using File → Export → Network As Graphics. Other options available include exporting your network as an interaction data file for use in other software packages.

Step 3: Exit Cytoscape by selecting File → Quit.

What Next?

Cytoscape is a powerful graphics editor and many complex procedures are described in the user manual. Here are a few of the tasks Cytoscape is capable of performing:

As an open-source project, many Cytoscape users have contributed plugins that extend Cytoscape's functionality. These plugins and their descriptions can be found online at and are downloadable free of charge. The plugins have been grouped into five general categories:

Return to the Cytoscape tutorials page.

GettingStarted (last edited 2012-08-09 08:17:17 by PietMolenaar)

Funding for Cytoscape is provided by a federal grant from the U.S. National Institute of General Medical Sciences (NIGMS) of the Na tional Institutes of Health (NIH) under award number GM070743-01. Corporate funding is provided through a contract from Unilever PLC.

MoinMoin Appliance - Powered by TurnKey Linux